[Ubuntu 14] init-checkconf fails "ERROR: failed to ask Upstart to check conf file"

May 18, 2015 3.5k views
Ubuntu DigitalOcean Articles Configuration Management System Tools Linux Commands

I have followed this tutorial:

https://www.digitalocean.com/community/tutorials/the-upstart-event-system-what-it-is-and-how-to-use-it

and got as far as the instructions to run “init-checkconf /etc/init/testjob.conf” and that’s where I’m stuck. It fails (after a few seconds), with the message:

 ERROR: failed to ask Upstart to check conf file

so all I know is that my startup task doesn’t work and I can’t figure out why. The checkconf process has written files to /tmp/ but they’re empty, so not much help there.

When I google for this, I find lots of people saying that installing or launching dbus will help. I have tried this and it’s still the same.

1 Answer

Try using using sudo init-checkconf /etc/init/testjob.conf. That’s what worked for me.

Have another answer? Share your knowledge.

You can type !ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!