Question

Ubuntu 20.04 - vsftpd confuses me

Posted June 7, 2021 85 views
Initial Server SetupUbuntu 20.04

After being disappointed with how slow the shared hosting setup was loading, I decided to just dive head first in and try to set everything up from scratch on my own on a VPS running Ubuntu 20.04 for the first time on my own.

I’ve been following some DigitalOcean guides and got LAMP set up and even got a security certificate setup. I’m very proud of me, even if its just following the script I at least understand more or less what’s going on. I haven’t worked in command lines since getting Doom II and Jazz Jackrabbit running as a kid, so I’m just glad I didnt break anything.

…until I tried to set up vsftpd. I’m trying to set up access so I can upload to what I remember as public_html, but would now be var/www/domain.ext, I think. The guides I find are to set up a user to upload to their own, separate folder…which isn’t apparently public facing through a browser, so I don’t think that’s what I need.

I was able to set up an account that had full access to view the server by going off-script from the guide, but i couldn’t delete or upload files. Sometime after that, I goofed something up setting up WordPress and wasn’t able to get the Apache test page to load, so I had the host just rebuild the server and started from scratch.

I’m back at the point where LAMP is set up, my domain points to the server and feeds the test files in var/www/domain.ext, and the SSL cert is working as it should. The firewall is set up, except for the FTP permissions since I haven’t installed vsftp yet. I decided to ask for help before going trying it again.

It could be less about vsftpd and more about not understanding file permissions and ownership. The guide I was using to understand that just went over my head, but I cant find it now on my mobile from work.

I can follow the guide to set up a chroot(?) jailed user, but I dont think that’s what I’m looking for. I may just be too green to know what to ask, so I appreciate the advice in advance. Thank you!

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

×
Submit an Answer
1 answer

I didn’t really answer my own question but I may have rendered it moot.

I ended up setting up a droplet here on DO instead and followed the guides to set up SSH and…I guess you can just SSH-FTP in and that’s what I really wanted to do and vsftpd and kick rocks, right?