Ubuntu doesn't pick up ipv6 config

January 20, 2018 2.3k views
IPv6 Networking DigitalOcean Articles Ubuntu Ubuntu 16.04

Hi all,

So I'm trying to setup ipv6 for my droplet following this instruction.

I've enabled ipv6 in DO panel after the creation and added following lines to the /etc/networking/interfaces:

# The primary network interface
auto eth0 
iface eth0 inet static
        address Y.Y.Y.Y
        netmask 255.255.224.0
        gateway Y.Y.Y.1
        up ip addr add 10.18.0.5/16 dev eth0
        dns-nameservers 67.207.67.2 67.207.67.3

iface eth0 inet6 static
        address 2a03:XXX:XXX:XXX:XXX:XXX:2001
        netmask 64
        gateway 2a03:XXX:XXX:XXX:XXX:1
        autoconf 0
        dns-nameservers 2001:4860:4860::8844 2001:4860:4860::8888 209.244.0.3

But after reboot system picks up only ipv4 settings and link-local ipv6 address

root@XXX:~# ip -6 a show dev eth0
2: eth0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 state UP qlen 1000
    inet6 fe80::8080:e2ff:fedb:ae11/64 scope link 
       valid_lft forever preferred_lft forever

At the same time, I can set up ipv6 manually using, say, ip command.

Can you please point what do I missing?

1 comment
2 Answers

That guide is outdated (for ubuntu, still works for debian)

https://wiki.ubuntu.com/Netplan

/etc/netplan/50-cloud-init.yaml

Ubuntu 18.04 has switched to netplan, the current guide hasn't been updated yet.
Follow this steps:

  1. (sudo) vim /etc/netplan/50-cloud-init.yaml
  2. In "addresses" section add
    • youripv6address/64
  3. Below "gateway4:..." section add a new section "gateway6: youripv6gateway"
  4. In "nameservers" -> "addresses" section add
    • 2001:4860:4860::8844
    • 2001:4860:4860::8888
    • 209.244.0.3
  5. (sudo) netplan apply
  6. ping6 2001:4860:4860::8888
Have another answer? Share your knowledge.