Question

ubuntu, nginx, wordpress and godaddy ssl

  • Posted June 18, 2013

I can activate the ssl cert but I can’t seem to redirect wordpress to https properly. I have tried with .htaccess > no luck, I tried with a https redirect in a virtual host (sites-availible) still no luck… Any takers?

Subscribe
Share

Submit an answer
You can type!ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

.htaccess doesn’t work with nginx - I thought you were using Apache. <br>I’m glad to hear you got it working properly! :]

I solved my ssl issue by copying the working http block settings into the https server block and all is well now, thx again

Thanks, but Im using wordpress on nginx without apache installed

Make sure mod_rewrite is enabled: (“sudo a2enmod rewrite && sudo service apache2 restart”) <br> <br>Try this in your .htaccess file: <br> <br>RewriteEngine On <br>RewriteCond %{HTTPS} off <br>RewriteRule (.*) https://%{HTTP_HOST}%{REQUEST_URI} <br> <br>Also make sure AllowOverride is set to All in your virtualhost config.

yes the site works directly via https and the latest htacces I tried was http://pastebin.com/7cHeV5YK. On http I’m getting 400 “The plain HTTP request was sent to HTTPS port”

Can you access https://yourdomain? Please pastebin the .htaccess file where you tried to set up redirection rules.