ubuntu, nginx, wordpress and godaddy ssl

Posted June 18, 2013 3.8k views
I can activate the ssl cert but I can't seem to redirect wordpress to https properly. I have tried with .htaccess > no luck, I tried with a https redirect in a virtual host (sites-availible) still no luck... Any takers?

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Submit an Answer
6 answers
Can you access https://yourdomain? Please pastebin the .htaccess file where you tried to set up redirection rules.
yes the site works directly via https and the latest htacces I tried was On http I'm getting 400 "The plain HTTP request was sent to HTTPS port"
Make sure mod_rewrite is enabled: ("sudo a2enmod rewrite && sudo service apache2 restart")

Try this in your .htaccess file:

RewriteEngine On
RewriteCond %{HTTPS} off
RewriteRule (.*) https://%{HTTP_HOST}%{REQUEST_URI}

Also make sure AllowOverride is set to All in your virtualhost config.
Thanks, but Im using wordpress on nginx without apache installed
I solved my ssl issue by copying the working http block settings into the https server block and all is well now, thx again
.htaccess doesn't work with nginx - I thought you were using Apache.
I'm glad to hear you got it working properly! :]