Ubuntu upgrade from 14.04 to 16.04 sort of failed

May 3, 2018 855 views
MySQL Apache Ubuntu 16.04

Hi,

Yesterday I tried to do-release-upgrade my droplet (mostly small Wordpress sites and some coding experiments).

I got lots of prompts asking for a hostname of a remote MySQL server. Like so:

Please provide the hostname of a remote MySQL server.
You must have already arranged for the administrative account to be able to remotely create databases and grant privileges. Host running the MySQL server for phpmyadmin:

I could not find any info on what that meant, so I cancelled all those prompts and decided it was probably best to roll back to my previous snapshot. So when more errors showed up, I tried to reject and cancel everything. I believe I was prompted about files being overwritten or not, and some sort of database update failure, which I just ignored. But unfortunately I was not paying attention since I wanted to roll back.

Then the upgrade finished and I was prompted about deleting obsolete packages, I ignored because I wanted to roll back.

But then I tested my wordpress sites, and coding experiments and node... and everything was working well. Ubutnu version shows as 16.04.4 LTS (GNU/Linux 4.4.0-122-generic x86_64) in the console, but the Digitalocean site lists it as Ubuntu 14.04 x64.

Should I be worried about something? Is my system 16.04 or 14.04? How can I make sure that files and databases are up to date?

My phpmyadmin shows the following warning:
The phpMyAdmin configuration storage is not completely configured, some extended features have been deactivated. Find out why.
Or alternately go to 'Operations' tab of any database to set it up there.

I tried removing obsolete packages manually following this post: https://askubuntu.com/questions/539235/how-to-remove-obsolete-packages-after-failed-release-upgrade-via-do-release-upgr

Any help is much appreciated

1 comment
1 Answer

The control panel is not aware of upgrades of a droplet's operating system after it is deployed. The OS and version shown in the control panel will always reflect whatever was last deployed to that droplet through the control panel. Since your droplet was created with an Ubuntu 14.04 image the control panel will continue to report it as 14.04.

Have another answer? Share your knowledge.