Question

Unable (550 error) to upload, create and modify files and folder on VSFTPD (on ubuntu)

Ftp users are unable to upload, create and modify files and folder on VSFTPD. (they could login and see files and folders, but they couldn’t modify)

My VPS is running ubuntu 14.04 LTS.

I installed VSFTPD to manage the folder of websites in /var/www/html/(userfolder). Then i installed XINETD to run VSFTPD.

About permissions: I tried to give to the main folder 766 755 and (just for test) also 777. I tried a lot of other configuration… …but, no one result…

I create user whit this: sudo useradd -c “example comment” -g ftp -m -k /dev/null -s /bin/false -d /var/www/html/(user-folder) user

After the creation of a user i run with root these 2 line:

chown (user):ftp /var/www/html/(folder)

chmod a-w /var/www/html/(folder)

What i failed???

# _________________________________
#                        My vsftpd.conf is this:
# _________________________________
#         File di configurazione Server FTP
#
# Acc
anonymous_enable=NO
anon_upload_enable=NO
anon_mkdir_write_enable=NO
# DIR SETTINGS
local_enable=YES
write_enable=YES
dirmessage_enable=YES
# LOG SETTINGS
xferlog_enable=YESiii
xferlog_file=/var/www/vsftpd.log
xferlog_std_format=YES
# CONNECTION SETTINGS
connect_from_port_20=NO
# listen=NO must be started from inetd whit: etc
listen=NO
listen_port=21
ftpd_banner=Welcome!
chroot_local_user=YES
check_shell=NO
# USERS SETTINGS
userlist_deny=NO
userlist_enable=YES
# WRITE ALLOWED USER IN IT
userlist_file=/etc/vsftpd.user_list
# PAM
# pam_service_name=/bin/false
# pam_service_name=vsftpd
pam_service_name=ftp
# Sand
seccomp_sandbox=NO


___________________________________

My XINETD.CONF is this:
___________________________________

# Simple configuration file for xinetd
#
# Some defaults, and include /etc/xinetd.d/

#defaults
#{
#
# Please note that you need a log_type line to be able to use log_on_success
# and log_on_failure. The default is the following :
# log_type = SYSLOG daemon info
#
#}

service ftp
{
	socket_type = stream
	wait = no
	user = root
	server = /usr/sbin/vsftpd
	log_on_success += DURATION
	nice = 10
	disable = no
}

includedir /etc/xinetd.d


The last error in the vsftpd’s log is this: Mon Jun 23 08:05:23 2014 1 7*.*.. 0 /sda.txt a _ i r (user) ftp 0 * i


The port 21 is open.


Submit an answer

This textbox defaults to using Markdown to format your answer.

You can type !ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

Sign In or Sign Up to Answer

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Want to learn more? Join the DigitalOcean Community!

Join our DigitalOcean community of over a million developers for free! Get help and share knowledge in Q&A, subscribe to topics of interest, and get courses and tools that will help you grow as a developer and scale your project or business.

Nothing changes… (the folder are now in 766 permission).

<quote>“The 550 error is a message from the server stating that the account you have currently logged in as does not have permission to perform the action you are attempting. You may be trying to upload to the wrong directory or trying to delete a file.” - <a href=“http://goo.gl/TEPRF4”>http://goo.gl/TEPRF4</a></quote>

Check if user has write permission in directory or if correct group is set.

Try: <code>chown -R user:group /var/www/your-folder-path</code>