Unable to access site after LetsEncrypt Install

March 14, 2018 1.7k views
WordPress Let's Encrypt Ubuntu 16.04

Hi, hopefully, someone can help.

Had my site up and running, access the console via SSH and followed the guide to install Lets Encrypt SSL.

Ran the commands and it confirmed it installed successfully, can see the certificate files etc. Then went to browse to the website but was unable to.

First thing I checked was the Wordpress URL was set correctly (Changed from http:// to https:// via wp-config. Restarted the server and still unable to browse to it.

Web URL Is https://caps-ltd.co.uk

The only error I can see in the Apache error.log is 'Could not reliably determine the server's fully qualified domain name, using 127.0.1.1. Set the 'ServerName' Which I don't believe is causing the issue.

I chose option 2 during the Let's Encrypt setup to redirect all traffic to https://

default le-ssl config looks like:

<IfModule mod_ssl.c>
<VirtualHost *:443>
        ServerAdmin webmaster@localhost
        DocumentRoot /var/www/html

        <Directory /var/www/html/>
            Options FollowSymLinks
            AllowOverride All
            Require all granted
        </Directory>

        ErrorLog ${APACHE_LOG_DIR}/error.log
        CustomLog ${APACHE_LOG_DIR}/access.log combined
SSLEngine On
ServerName caps-ltd.co.uk
SSLCertificateFile /etc/letsencrypt/live/domain/fullchain.pem
SSLCertificateKeyFile /etc/letsencrypt/live/domain/privkey.pem
Include /etc/letsencrypt/options-ssl-apache.conf
</VirtualHost>
</IfModule>

Anyone got any advice on what I have done wrong at all?

Thank you.

1 Answer

I can access your website just fine over HTTPs. Were you able to figure it out? Also, there is an image in the footer that is loading over HTTP—you need to replace that with an HTTPS link in order to see the green HTTPS lock icon in the URL bar.

  • Hi Kamlan,

    After typing all that out, it twigged - I was using Cloudflare in front of the website which was interfering with the SSL - Real amateur mistake!!

    Thanks for the heads up on the HTTP footer logo, have got rid of it for now and that's sorted everything out.

    Thanks for taking the time, appreciate it.

Have another answer? Share your knowledge.