Question

Unable to add droplet to load balancer

Posted April 29, 2020 523 views
DigitalOcean Managed Load Balancers

I have a droplet in NYC1 region. It is not attached to any load balancer. I created a new load balancer in NYC1 region. During creation it asks to add droplets - I could not find droplets there, so I went ahead and created the load balancer without droplets. Later, I tried to add droplet again to this new load balancer and still no luck.

My droplet name starts with “pool” and I find nothing when I search for pool.

The droplet is created via do k8s, where as load balancer is created from online do panel. Does it matter?

I have another 2 year old load balancer in same NYC1 region, but even if I try to add droplet to it, no droplets are found!

Is this a bug or something?

1 comment

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

×
Submit an Answer
1 answer

DO Kubernetes is separate from DO droplets. If you want to use Load Balancers with droplets you can do that from the configuration method as you have already attempted.

However, since Kubernetes is itself a management layer for resources, you shouldn’t be linking a load balancer directly to a specific resource inside of Kubernetes as those are made to be created and destroyed frequently depending on usage, so you are going against the intended purpose of Kubernetes design.

For what you are looking to achieve you should follow this resource:
https://www.digitalocean.com/docs/kubernetes/how-to/add-load-balancers/