Question

Unable to boot and stuck at random: nonblocking pool is initialized

Hi, i have difficult (stuck actually) to boot my droplet after i use command reboot.

What action i done before i re-boot:

  • Stop PHP/Apache/MySQL/Nginx
  • chmod 700 and rename a web application folder
  • Clean /var/log via command rm .log.
  • reboot
  • Stuck forever

Console Screen for Reference: http://imgur.com/a/9Q2CG http://imgur.com/a/9Q2CG

Few times of tried power cycle and power off, no luck to boot up anything just stuck at the command as attached screen shot, and also tried New Droplet from Snapshot and Other Region Droplet and Size but no luck again.

Sometimes stuck at random: nonblocking pool is initialized, can be quite a long time to reach this line.

BTW, i open a support ticket but seems all the staff are going holidays ? And anyway i can get help ?

Thanks.


Submit an answer

This textbox defaults to using Markdown to format your answer.

You can type !ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

Sign In or Sign Up to Answer

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Want to learn more? Join the DigitalOcean Community!

Join our DigitalOcean community of over a million developers for free! Get help and share knowledge in Q&A, subscribe to topics of interest, and get courses and tools that will help you grow as a developer and scale your project or business.

At this situations, Support can only help you. There is nothing reported but maybe there slow downs on responses due to transferring to new system, however this should be already over (update: there are actually some difficulties at the time of writing answer).

You need to make sure you didn’t applied chmod to wrong directory, or deleted /var/log or something similar.

Try getting Support to mount you Recovery Image. Backup the data, transfer it to your PC and start digging. Verify permissions on /var, /var/www and /var/log directories. Try reverting /var/www to 755, not really sure why you went with 700. Also, make sure ownership is correct. You can check it with ls -l /var/www for example. Make sure it’s root:root or www-data. Similar applies to /var - it should be 755 with ownership to root:root.

Good luck with getting it up if you didn’t already.