Unable to bootup droplet,

March 7, 2018 397 views
DigitalOcean WordPress

My console said "/dev/disk/by-uuid/4d444fea-ef77-44b9=9678-76a2c5e02620 does not exist. Dropping to a shell!".

I followed this: https://www.digitalocean.com/community/tutorials/how-to-recover-from-file-system-corruption-using-fsck-and-a-recovery-iso.

The command blkid returns '/dev/vda1: LABEL="DOROOT" UUID=011bb24a-5d10-42df-b584-3d47fdff51c8" TYPE="ext4"' as the page commanded but I'm unsure what to do with that.

My droplet is stuck on initramfs on bootup and I read a post on here that told me to request a bootable recovery ISO attached to my droplet for troubleshooting purposes, and I've been waiting roughly 9 hours on that.

I've tried booting up an older snapshot that I know worked in the past and I get the same error and it boots up to BusyBox v1.21.1 built-in-shell.

Is ANY of my data still there? How can I be sure?

3 Answers

Your data should still be on the Volume.

/dev/disk/by-uuid/4d444fea-ef77-44b9=9678-76a2c5e02620 does not exist. Dropping to a shell!
blkid returns `/dev/vda1: LABEL="DOROOT" UUID=011bb24a-5d10-42df-b584-3d47fdff51c8" TYPE="ext4"

Your Droplet is having trouble mounting the Volume because the UUIDs do not match. Edit /etc/fstab and remove the link that mounts the Volume. This should allow you to reboot into your Droplet regularly.

Then, follow this tutorial to attach the Volume to your Droplet correctly. Specifically, Preparing an Existing, Formatted Volume under Preparing Volumes for Use in Linux: https://www.digitalocean.com/community/tutorials/how-to-use-block-storage-on-digitalocean#preparing-volumes-for-use-in-linux

I had run in the same problem, steps that i took:
Using initramfs prompt in digital ocean console (droplet page):

  blkid
  mkdir mnt
  mount /dev/vda1 /mnt
  mv /mnt/etc/fstab /mnt/etc/fstab.bck
  echo 'UUID=xxxxx ... ' >> /mnt/etc/fstab

However this did not work because the root is hardcoded in grub startup command line.

 cat /proc/cmdline

Reboot the machine

reboot

Press arrow down to stop at the grub selection, select Advanced Options for Ubuntu
Highlight the desired kernel (default one)

Press e to edit command line

Replace the UUID obtained from the blkid above (it has 3 instances, the last one was enough)

Ctrl-X to save and reboot

The change is only temporary, after rebooting the server (it should work by now) login in to the box and run

sudo update-grub

That fixed it, I had a ticked open during all this time but no reply to it. Also i almost learned the UUID
due to typing it so many times in to the digital ocean console. There is a javascript utility that can help with copy paste that i found later: https://gist.github.com/croepha/7b53f211ae4be3c526c3

  • kamaln7,

    Thanks!!!!! It worked, I was also waiting for a ticket and no answer yet. Luckily I stumbled upon your answer.

  • This also worked for me.

This worked for me too. Thanks.

I wasn't able to start my VS after that, at DO, they did something connected to Meltdown and Spectre vulnerabilities.

In the answer above, I don't understand what is the blkid command: it is not known in the in (initramfs) context, where the boot was aborting.
Moreover, I wasn't able to enter some characters (such as the front slash: '/') in the horrible console: bad keyboard layout, no possibility of scrolling the screen buffer.

However, by navigating the file-system, in the dev/by-uuid directory I found only one device with an ID with the same format as the missing one.
After interrupting reboot, I edited the script as explained above and this time the boot completed successfully.

Have another answer? Share your knowledge.