Question

Unable to create directory wp-content/uploads/2013/04. Is its parent directory writable by the server?

  • Posted April 21, 2013

does anyone have any idea how to solve it . i am running arch with nignx.

Subscribe
Share

Submit an answer
You can type!ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

@prasad0889: What’s the output of <pre>sudo ps wwaux | grep php</pre>?

Hi, <br> <br>System : I have centos 6 with nginx. I have installed ghost and wordpress on the server. <br> <br>I have tried the above methods but it doesnt help. <br>I have restarted nginx, mysql, php-fpm and also rebooted the server, but it still shows me the error “Cant create directory”. <br> <br> <br>Please help me.

@Jason: Try running <pre>sudo chmod -R g+w /var/www/wordpress/wp-content <br>sudo chgrp www-data /var/www/wordpress/wp-content</pre>

Hmm… this isn’t working for me for some reason. Here is what I get with ps -elf | grep nginx: <br>$ ps -elf | grep nginx <br>55:1 S root 700 1 0 80 0 - 1501 rt_sig 20:24 ? 00:00:00 nginx: master process /usr/sbin/nginx -c /etc/nginx/nginx.conf <br>56:5 S www-data 702 700 0 80 0 - 1659 ep_pol 20:24 ? 00:00:00 nginx: worker process <br>72:0 S vagrant 874 32356 0 80 0 - 1156 pipe_w 20:33 pts/0 00:00:00 grep --color=auto -in nginx <br> <br>I’ve tried everything - changing permissions and ownership so I can upload plugins and images to my WordPress install. I’m really not understanding why it’s not working. Really frustrating! <br> <br>

Also use this command to find out what user owns the nginx worker processes <br> <br>ps -elf | grep nginx <br> <br>In my above comment “nginx” was the name of the user who owned the process.

I’m by far from an expert but this worked for me <br> <br>chgrp nginx /var/www/wordpress/wp-content <br>sudo chown nginx /var/www/wordpress/wp-content

not nginx expert but i think same as apache www-data <br>chmod your directory and you should be fine

Which user is nginx running under? Which group owns wp-content/uploads? What are the chmod permissions on wp-content/uploads?