Question

Unable to delete plugins, Wordpress, Nginx, PHP5-fpm

  • Posted February 13, 2015

Hello friends. I’ve just recently setup Ubuntu 14.04 with LEMP and WP. Everything seems to be working fine, I can install themes, updates and plugins just fine through SSH but when I try to delete a plugin I get an error from Nginx.

“Sorry, the page you are looking for is currently unavailable. Please try again later.”

I’ve tried to figure this out myself but seems like I am lacking some understanding. (First time using nginx and php5-fpm) and not that well versed in the linux world to begin with. One search presented this to me which feels relevant but I don’t quite get it. http://serverfault.com/questions/543999/nginx-errors-recv-failed-104-connection-reset-by-peer-while-reading-respon

Here are some logs and confs that I’ve located.

/var/log/syslogstates (within relevant timeframe: )

Feb 13 17:54:02 foobar kernel: [114562.103944] php5-fpm[23122]: segfault at 0 ip 00007fe72c04467a sp 00007fff01d93208 error 4 in libc-2.19.so[7fe72bfbb000+1bb000]

dmesg states

[116034.211123] php5-fpm[23698]: segfault at 0 ip 00007fb34316167a sp 00007fff8aca4448 error 4 in libc-2.19.so[7fb3430d8000+1bb000]

/var/log/nginx/error.log - http://pastebin.com/L80LB14v

/var/log/php5-fpm.log doesn’t have any content for correct day, only list successful tests from installation.

/etc/pgp5/fpm/php-fpm.conf - http://pastebin.com/NxpadapV /etc/nginx/nginx.conf - http://pastebin.com/07XP2dCP

From a fresh droplet with Ubuntu 14.04 I did the following tutorials.

  1. https://www.digitalocean.com/community/tutorials/how-to-connect-to-your-droplet-with-ssh ( All three steps ).
  2. https://www.digitalocean.com/community/tutorials/how-to-install-linux-nginx-mysql-php-lemp-stack-on-ubuntu-14-04
  3. https://www.digitalocean.com/community/tutorials/how-to-install-wordpress-with-nginx-on-ubuntu-14-04
  4. https://www.digitalocean.com/community/tutorials/how-to-configure-secure-updates-and-installations-in-wordpress-on-ubuntu

Thanks in advance for the help. Sinecerly . martin

Subscribe
Share

Submit an answer
You can type!ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Confirmed bug in Wordpress. Solution: https://core.trac.wordpress.org/ticket/31167

I solved this by editing class-wp-filesystem-ssh2.php as he mentions in his bug report.

Confirmed bug in Wordpress. Solution: https://core.trac.wordpress.org/ticket/31167

I solved this by editing class-wp-filesystem-ssh2.php as he mentions in his bug report.

Confirmed bug in Wordpress. Solution: https://core.trac.wordpress.org/ticket/31167

I solved this by editing class-wp-filesystem-ssh2.php as he mentions in his bug report.

Thanks alot! It helps!

This helped me too!!! Thanks for coming back and posting the solution.