Unable to download kubernetes config

When I click the download config button I get a 500 server error

Submit an answer

This textbox defaults to using Markdown to format your answer.

You can type !ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

Sign In or Sign Up to Answer

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Accepted Answer

Could you try again? There was an issue on our end, but it should be resolved now.

Want to learn more? Join the DigitalOcean Community!

Join our DigitalOcean community of over a million developers for free! Get help and share knowledge in Q&A, subscribe to topics of interest, and get courses and tools that will help you grow as a developer and scale your project or business.

I successfully downloaded a config just now, so it’s working for me.

If it helps, there are three ways to download: on the main “Kubernetes” panel which shows a summary of all clusters there’s a pulldown menu marked “More V” to the right of each cluster summary, and “Download Config” is one of the pulldown options. On the screen for a a given cluster, each sub-panel (Overview, Notes, Settings) has a “Config” button on the right in blue letters. Finally, when you move to the “Overview” sub-panel, there’s a big blue-background button with “Download Config” in white letters. I tried all three just now, and they all worked.

FWIW, personally I’d rather they make config downloading a fourth sub-panel. There’s plenty of room for it. The new sub-panel would have the button to start the download, and also show the config right there on the screen in plain text for people who want to read the config without downloading it. There could also be some instructions right to the download button for newbies like me who have to sift through the docs to remember what we’re supposed to do with it.

any workaround we can use?

Same, sadly.