Question

Unable to enable remote api access

As I’ve created API token via dashboard, access to the lotus-filecoin console, and follow the instruction via this link --> https://docs.filecoin.io/build/lotus/enable-remote-api-access/

I did input the ListenAddress = “filecoinlotus1130onubuntu2004lts-s-4vcpu-8gb-intel-ams3-01” #

The error stated as "command not found: ListenAddress

The format given is ListenAddress = “/ip4/<EXTERNAL_INTERFACE_IP>/tcp/3453/http” # port is an example

But, where can I obtain the information in my Dashboard for “/ip4/<EXTERNAL_INTERFACE_IP>/tcp/3453/http” # port is an example?

Looking forward to your reply with guidance accordingly.

Thanks so much.


Submit an answer

This textbox defaults to using Markdown to format your answer.

You can type !ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

Sign In or Sign Up to Answer

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Hi there,

Would you mind providing a bit more information on what kind of API are you building exactly?

The ListenAddress does not really sounds like a shell command but more of a configuration value based on the specific API service that you are using. Can you share the name of the service that you are using so I could check the docs?

Best,

Bobby

Hi @jennifersim,

Can you please provide a little bit more information on the matter? hat exactly are you trying to achieve, how are yu going about the problem, what API, have you enabled DigitalOcean’s API?