Unable to figure out how to put load balancer's IP under https

So I was playing with load balancers today, I created one through kubernetes config shown further down. This Load Balancer works correctly, I can access my kubernetes cluster, however I can only do so via http://[my-load-balancer-ip]

I was trying to figure out how to put this load balancer under its own domain and https whole day today, but was empty handed.

I already added my domain to DigitalOcean and it was really easy to point to my load balancers ip. However modern browsers always overwrite http to https so whenever I try to connect I get connection error page.

My only settings in load balancer are forwarding between TCP on port 80 -> TCP on port 30... I tried setting up https and http rules here as well, created new certificate, but still no luck.

Can anyone explain how to set this up and why is this not automatically done, as it is mentioned on page.

apiVersion: v1
kind: Service
    app: my-server
  name: my-server
  namespace: default
  - name: http
    port: 80
    protocol: TCP
    targetPort: 8080
    app: my-server
  type: LoadBalancer

Submit an answer

This textbox defaults to using Markdown to format your answer.

You can type !ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

Sign In or Sign Up to Answer