Question

Unable to get SendMail to work.

  • Posted on December 29, 2013
  • dbtoomeyAsked by dbtoomey

I set up my mx record to be “mail” with priority one. I am able to successfully ping mail@my-domain.com

I’ve followed this documentation: https://wiki.archlinux.org/index.php/sendmail

I then:

$ sendmail -vt < test-message.txt

The output looks like this (please note that I changed some of the stuff to hide my droplet name, domain name, and username. I’ve cap-locked those parts to make it obvious.

WARNING: local host name (DROPLET) is not qualified; see cf/README: WHO AM I? TEST@EMAIL.COM… Connecting to [127.0.0.1] via relay… 220 MY-DOMAIN.COM ESMTP Sendmail 8.14.7/8.14.7; Mon, 23 Dec 2013 06:00:31 GMT

EHLO camille 250-MY-DOMAIN.COM Hello localhost.localdomain [127.0.0.1], pleased to meet you 250-ENHANCEDSTATUSCODES 250-PIPELINING 250-EXPN 250-VERB 250-8BITMIME 250-SIZE 250-DSN 250-ETRN 250-DELIVERBY 250 HELP VERB 250 2.0.0 Verbose mode MAIL From:MY-LOGIN@MY-DROPLET SIZE=111 050 MY-LOGIN@MY-DROPLET… Transient parse error – message queued for future delivery 553 5.1.8 MY-LOGIN@MY-DROPLET… Domain of sender address MY-LOGIN@MY-DROPLET does not exist …/dead.letter… Saved message in …/dead.letter Closing connection to [127.0.0.1] QUIT 221 2.0.0 MY-DOMAIN.COM closing connection


Submit an answer

This textbox defaults to using Markdown to format your answer.

You can type !ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

Sign In or Sign Up to Answer

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Want to learn more? Join the DigitalOcean Community!

Join our DigitalOcean community of over a million developers for free! Get help and share knowledge in Q&A, subscribe to topics of interest, and get courses and tools that will help you grow as a developer and scale your project or business.

Thanks for all the help guys. It turned out that I should have simply ignored that error. I sent a test email from the site and it works. <br>

What operating system are you running?

I set up the MX record and went through setting up sendmail again, but still no dice. <br> <br>I still get the same error as here: <br>Domain of sender address MY-LOGIN@MY-DROPLET does not exist <br> <br>I would list all the sites and blogs I looked into for answers, but nothing seems to be working.