Question

Unable to import theme data wordpress droplet

I have setup wordpress droplet on X.X.X.X. I have setup https using cloudfare.

Whenever I try to install theme I get this error :

An error occurred while fetching file from: https://bestsportsnews.info/wp-content/themes/buzznews/spiderbuzz/demo-import/default/content.xml! Reason: http_request_failed - cURL error 7: Failed to connect to bestsportsnews.info port 443: Connection refused.

I tried sshing into instance and curl -vv https://bestsportsnews.info . But there also I got

curl: (7) Failed to connect to bestsportsnews.info port 443: Connection refused

I checked ufw and it seems 443 is enabled.

To Action From


22/tcp LIMIT Anywhere
443/tcp ALLOW Anywhere
80/tcp ALLOW Anywhere
22/tcp (v6) LIMIT Anywhere (v6)
443/tcp (v6) ALLOW Anywhere (v6)
80/tcp (v6) ALLOW Anywhere (v6)

Please help me fix this.


Submit an answer

This textbox defaults to using Markdown to format your answer.

You can type !ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

Sign In or Sign Up to Answer

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Want to learn more? Join the DigitalOcean Community!

Join our DigitalOcean community of over a million developers for free! Get help and share knowledge in Q&A, subscribe to topics of interest, and get courses and tools that will help you grow as a developer and scale your project or business.

@MattIPv4 , Oh man. That solved it ! Not sure exactly what the issue was.

Hey @MattIPv4 ,

it doesnt work when executing the same command from the local machine itself.

Hey @bestnerdever,

It looks like the issue you were experiencing has now been resolved as when I make a curl request to https://bestsportsnews.info, it works fine, returning the content of the website. Additionally, if I open the XML file that was failing in my browser, it finds the content correctly.

I’d love to know what the issue was and how you resolved it! - Matt.