Question

Unable to Install Mail Server on Ubuntu

I had bought two droplets from Digital Ocean a couple of weeks back. I have built an SMTP on first droplet using SSH Putty and all the process gone well :)

Now, I am trying to build another SMTP on the second droplet by following the same procedure but this time I am getting an error:

“The repository ‘http://ppa.launchpad.net/brightbox/ruby-ng/ubuntu focal Release’ does not have a Release file.”

Here is the log image: https://imgur.com/3AfYqh6

I have also tried to build an SMTP using Postal, but I am getting the same error here as well.

How can I figure our this issue? Any help from the community would be appreciated!

VPS OS: Ubuntu 20.04 (LTS) x64


Submit an answer

This textbox defaults to using Markdown to format your answer.

You can type !ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

Sign In or Sign Up to Answer

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Want to learn more? Join the DigitalOcean Community!

Join our DigitalOcean community of over a million developers for free! Get help and share knowledge in Q&A, subscribe to topics of interest, and get courses and tools that will help you grow as a developer and scale your project or business.

Hi there @DanAskew,

The error that you are seeing is for the Brightbox Ruby NG repository which you have added to your server and saying that this repository is not available for your current Ubuntu version.

You would need to remove the http://ppa.launchpad.net/brightbox/ruby-ng/ubuntu focal Release repository from your repository source list and then run sudo apt update.

To do so first run:

apt policy

Thich will list all of the PPA repositories that you have.

  • Then find the exact PPA repository that you want to remove and run the apt-add-repository but add the --remove flag:
sudo apt-add-repository --remove ppa:brightbox/ruby-ng

Finally, you will need to run:

sudo apt update

After that apt will start working as normal.

Let me know how it goes. Regards, Bobby