Question

Unable to install mongodb on ubuntu 16.04

Team,

I am trying to install mongodb on ubuntu 16.04 as per steps given in this link :

https://www.digitalocean.com/community/tutorials/how-to-install-mongodb-on-ubuntu-16-04 When I run this command it gives following message :

But its failing on the step 2 - “Installing and Verifying MongoDB”.

Some packages could not be installed bla bla bla. …

The following packages have unmet dependencies.

mongodb-org : Depends : mongodb-org-tools but it is not going to be installed.

E: Unable to correct problems, you have help broken packages.

Can some one help me get through this. I have a screen shot of console. Let me know if you want me to send via email.

Show comments

Submit an answer

This textbox defaults to using Markdown to format your answer.

You can type !ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

Sign In or Sign Up to Answer

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Want to learn more? Join the DigitalOcean Community!

Join our DigitalOcean community of over a million developers for free! Get help and share knowledge in Q&A, subscribe to topics of interest, and get courses and tools that will help you grow as a developer and scale your project or business.

This comment has been deleted

You didn’t follow all the steps that are a part of “Step 1” on that tutorial.