Question

Unable to locate private key when setting up Filezilla (Windows)

Beginner here. I’m setting up Filezilla to connect with my Droplet and am following the tutorial below to set up.

https://www.digitalocean.com/community/tutorials/how-to-use-filezilla-to-transfer-and-manage-files-securely-on-your-vps

I’m able to SSH to my Droplet no problem and have used bash to see i have both private and public keys in the ssh directory

I head to Edit -> Settings -> SFTP -> Add key file but can not find the id_rsa key under the .ssh directory

I try authorizing through Site Manager by using server log ins and see this

Status: Server refused our key Error: FATAL ERROR: No supported authentication methods available (server sent: publickey)

I tried converting to ppk format with Putty but again am unable to find the key files when I try to load keys.

I’m sure I’m missing something obvious. Thanks in advance for any advice on this.

Show comments

Submit an answer

This textbox defaults to using Markdown to format your answer.

You can type !ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

Sign In or Sign Up to Answer

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Want to learn more? Join the DigitalOcean Community!

Join our DigitalOcean community of over a million developers for free! Get help and share knowledge in Q&A, subscribe to topics of interest, and get courses and tools that will help you grow as a developer and scale your project or business.

Nevermind! Just found out Ubuntu files are hidden so I searched for the file name, looked for file path under properties, and worked my way backwards. Thank you!

https://www.howtogeek.com/261383/how-to-access-your-ubuntu-bash-files-in-windows-and-your-windows-system-drive-in-bash/