I’m having issues pointing my domain to my IP.

My django app is deployed at : without an issue, but I cannot point a domain I bought: magnacreativelabs.club to the IP.

My Domain has a custom DNS of:

And my DNS configuration in DigitalOcean looks like:

A *.magnacreativelabs.club directs to
A magnacreativelabs.club directs to
A www.magnacreativelabs.club directs to

NS magnacreativelabs.club directs to ns3.digitalocean.com
NS magnacreativelabs.club directs to ns1.digitalocean.com.
NS magnacreativelabs.club directs to ns2.digitalocean.com.

Even further:

my /etc/sites-available/MYAPP looks like:

server {

listen 80;
server_name magnacreativelabs.club;

location = /favicon.ico { access_log off; log_not_found off; }
location /static/ {
    root /home/michael/magna/magna/magna;

location / {
    include proxy_params;
    # proxy_pass;
    proxy_pass http://unix:/home/michael/magna/magna/magna.sock;


and /etc/sites-available/default looks like:

server {
listen 80 defaultserver;
listen [::]:80 default

    root /var/www/html;

    index index.html index.htm index.nginx-debian.html;

    server_name _;

    location / {
            try_files $uri $uri/ =404;


Any help would be appreciated!

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Submit an Answer
2 answers

Real issue maybe your sites-enabled not symlinked. Run this on terminal:

  • sudo ln -s /etc/nginx/sites-available/*.conf /etc/nginx/sites-enabled/

Nginx uses two separate folders, only confs in sites-enabled run.

You only need one A and a CNAME record to make it work.

  • Keep only this A record: A magnacreativelabs.club directs to removing other A’s.
  • Add a CNAME named www pointing to @
  • nginx server_name .magnacreativelabs.club;

I have issues pointing my droplet to cloudflare. Would be great if someone can help me!