Question

unable to run bash file

i created droplet of ubuntu 12.04 64bit and trying to install Network simulator. but when i run command ./install i got following error: -bash: ./install: permission denied any help will be appreciated! thank you


Submit an answer

This textbox defaults to using Markdown to format your answer.

You can type !ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

Sign In or Sign Up to Answer

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Want to learn more? Join the DigitalOcean Community!

Join our DigitalOcean community of over a million developers for free! Get help and share knowledge in Q&A, subscribe to topics of interest, and get courses and tools that will help you grow as a developer and scale your project or business.

@errahulwadhwa

There’s a few ways to execute the file. First, you can give it execution rights using:

chmod +x install.sh

and then run ./install or you can use:

bash ./install

Have you tried running it under sudo? So:

sudo ./install

If you are installing likely needs different permissions, if not I’d say confirm the requirements of your Network Simulator.