I am relatively new to Node.js and Digitalocean. I have a website hosted on digitalocean - www.domainname.com. The domain name was registered with GSuite. I want to send a verification email from support@domainname.com to a gmail address, say example@gmail.com.

I tried using the nodemailer module for this. When I try to send an email from my my own gmail address I can send the verification link to any email account. But when I try to send an email from ’support@domain.com’, I get ‘Invalid login’ error in the log files.

I use the following code to send the email:

var mail=example@gmail.com;
var code="*******";
var nodemailer = require('nodemailer');

var transporter = nodemailer.createTransport({
      service: 'gmail',
      auth: {
        user: 'support@domainname.com',
        pass: 'password'
      }});
    var mailOptions = {
      to: mail,
      subject: 'Verify your account',
      text: 'Veify your account',
        html: " <a href='http://www.domainname.com/verification?code="+code+"'> http://www.domainname.com/verification?code="+code+"  </a> "
    };
    transporter.sendMail(mailOptions, function(error, info){
      if (error) {
        console.log(error);
      } else {
        console.log('Email sent: ' + info.response);
      }
    });

This is the error message in the log file:

Error: Invalid login.
<https://accounts.google.com/signin/continue?sarp=1&scc=1&plt=AKgnsbv
Please log in via your web browser and then try again.
Learn more at https://support.google.com/mail/answer/78754

Any help would be appreciated…

edited by kamaln7

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

×
3 answers

Hi -
I see this post is old, but I am experiencing the same issue . Any suggestion?
Thanks!

I am also experiencing the same problem. any change we can escalate this?

Hey,
I have also experienced the same issue earlier today and enabling UnlockCaptcha has resolved this issue, (https://accounts.google.com/b/0/DisplayUnlockCaptcha) try enabling this option to your Gmail account which you’re using in nodemailer.

Submit an Answer