Question

Unable to send mail

Recently I have installed Wordpress on my nginx server after Installing I’m getting this error

Possible reason: your host may have disabled the mail() function.``` 

While resetting my password. Why this error happened and how to solve this. My server config is Ubuntu 16.04, Nginx 1.12.1 and WordPress 4.7.5.
Subscribe
Share

Submit an answer
You can type!ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Hello all,

What I could suggest here is using an SMTP plugin for your WordPress site.

That way you will be able to specify an SMTP server with authentication which your emails would be going through. You could for example use Gmail’s SMTP settings. This would drastically increase the delivery rate of your emails as well compared to using plain PHP mail.

I’ve been using this plugin for a while now and it works very well: Easy WP SMTP

Hope that this helps! Regards, Alex

Hello all,

What I could suggest here is using an SMTP plugin for your WordPress site.

That way you will be able to specify an SMTP server with authentication which your emails would be going through. You could for example use Gmail’s SMTP settings. This would drastically increase the delivery rate of your emails as well compared to using plain PHP mail.

I’ve been using this plugin for a while now and it works very well: Easy WP SMTP

Hope that this helps! Regards, Alex

@sasuke

By default DigitalOcean blocks sending emails from droplets, if your issue is not resolved as described by @Aprexer then you must create a support ticket to lift the block.

Hope this helps.