Question

Unable to send mail through smtp.gmail.com

  • Posted March 10, 2014

I have recently become unable to send any e-mail from my Django app hosted on a DO droplet through smtp.gmail.com. Any time I try, I get the following error message:

SMTPAuthenticationError (535, ‘5.7.8 Username and Password not accepted. Learn more at\n5.7.8 http://support.google.com/mail/bin/answer.py?answer=14257 sh5sm32272477pbc.21 - gsmtp’)

Which is weird, because the username and password used works perfectly when I try to log in manually, or when sending through the exact same Django app from localhost.

I have also tried going through http://www.google.com/accounts/DisplayUnlockCaptcha , as mentioned in the Google support answer.

I have been sending at maximum a couple of hundred e-mail in total from that account, with maybe ~10 a day - so abuse seems to be out of the question for me. I should mention that the account is a paid Google Apps account.

The fact that I can use the exact same settings while using localhost as a server, plus the fact that this error has only appeared recently, makes me think that the error might have something to do with Digital Ocean.

Do you have any ideas about what might cause this?

Thanks and with the best regards, Martin

Ps. for good measure, here are my smtp settings, minus the password (which I am 100% sure is correct):

EMAIL_USE_TLS = True EMAIL_HOST = ‘smtp.gmail.com’ EMAIL_PORT = 587 EMAIL_HOST_USER = ‘info@CoCreately.com’ EMAIL_HOST_PASSWORD = <redacted>

Subscribe
Share

Google now doesn’t accept login from less secure apps. So you need to go to https://myaccount.google.com/security scroll to the bottom and turn ON “Allow less secure apps: ON”. Now when you add the SMTP details to “Send as” google will accept them. You need to do this for the email ID you are adding in your Send as section.

@omarg55 you need to turn on “Access for less secure apps” on the gmail account you are trying yo use

Hi, Firstly you should activate two factor authentication on your gmail account and should change the “Access for less secure apps” to Enabled at This Link after that must set a application password for your application via using This Link then it will work

@cartocri it is ready “Access for less secure apps”, but again warming SMTP server did not accept the password. ‘EmailTransport’ => [ ‘default’ => [ ‘className’ => ‘Smtp’, // The following keys are used in SMTP transports ‘host’ => ‘ssl://smtp.gmail.com’, ‘port’ => 465, ‘timeout’ => 30, ‘username’ => ‘xxx@gmail.com’, ‘password’ => ‘xxx’, //‘client’ => null, //‘tls’ => true,

any update abount this error, i mean, at cakephp -> EmailTransport same description, but i have this error. SMTP server did not accept the password. Cake\Network\Exception\SocketException

encountered the same issue. But solved after generating a new app password for Digital Ocean server from here https://security.google.com/settings/security/apppasswords and using it.

Same issue with my droplet. Anyone can help?

Any resolution for this issue?. Two of my earlier deployments work fine, but the newest one is giving this issue. Can’t find a resolution

We are experiencing the same issue. We can be sure that the Gmail server settings and code is correct, as our production server (on different infrastructure, same domain) works fine and is currently sending emails. Only our development server which is hosted on Digital Ocean fails to send emails and gets the same message listed above.

Is it possible that the Digital Ocean subnet has been blacklisted by Gmail?


Submit an answer
You can type!ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

  1. Go to admin.google.com
  2. From the admin console, select “Security”
  3. Select “Basic settings”
  4. Scroll down to “Less secure apps”
  5. Go to settings for less secure apps ››
  6. Check the radio button “Allow users to manage their access to less secure apps”
  7. Save the changes
  8. Open this link being sign in as the super administrator https://www.google.com/settings/security/lesssecureapps
  9. Check the radio button Turn On the access for less secure apps
  10. Unlock Captcha using this link https://accounts.google.com/DisplayUnlockCaptcha

Hey guys, just found what’s going on with those errors.

The problem is that when you have activated the Google Authenticator Verification you also need to set up the 2-Step-Authentication in your gmail account.

Therefore visit https://www.google.com/settings/security - when you have done so, just go back to this page and click the “App Password” - Settings.

Select “Other (custom name)” and enter any name you like. Go ahead and copy the code and paste it to your projects settings.

Done! - This resolved all issues for me.

Greets P4rks!

Hey guys, just found what’s going on with those errors.

The problem is that when you have activated the Google Authenticator Verification you also need to set up the 2-Step-Authentication in your gmail account.

Therefore visit https://www.google.com/settings/security - when you have done so, just go back to this page and click the “App Password” - Settings.

Select “Other (custom name)” and enter any name you like. Go ahead and copy the code and paste it to your projects settings.

Done! - This resolved all issues for me.

Greets P4rks!

Hey guys, just found what’s going on with those errors.

The problem is that when you have activated the Google Authenticator Verification you also need to set up the 2-Step-Authentication in your gmail account.

Therefore visit https://www.google.com/settings/security - when you have done so, just go back to this page and click the “App Password” - Settings.

Select “Other (custom name)” and enter any name you like. Go ahead and copy the code and paste it to your projects settings.

Done! - This resolved all issues for me.

Greets P4rks!

Hey guys, just found what’s going on with those errors.

The problem is that when you have activated the Google Authenticator Verification you also need to set up the 2-Step-Authentication in your gmail account.

Therefore visit https://www.google.com/settings/security - when you have done so, just go back to this page and click the “App Password” - Settings.

Select “Other (custom name)” and enter any name you like. Go ahead and copy the code and paste it to your projects settings.

Done! - This resolved all issues for me.

Greets P4rks!

I had the same problem. I guess it’s a gmail ban, because the Gmail send a mail with this link: https://support.google.com/mail/answer/14257?p=client_login&rd=1

The point is this: https://www.google.com/settings/security/lesssecureapps

You should change the “Access for less secure apps” to Enabled (it was enabled, I changed to disabled and than back to enabled). After a while I could send email.

I have the same issue running CakePHP, and completely sure that it’s not a GMAIL ban, because i have the exactly same app running in another server and it is still sending emails… : ( <br>

I believe gmail limits the amount of emails you can send per day. You probably passed that limit. I recommend using a transactional mail service such as Mandrill or SendGrid.

I was facing the same issues. i had to make sure i cross checked and be sure my gmail username and password was correct, and also made sure my internet connection was good.

try using instructions from this web https://codewithmukesh.com/blog/send-emails-with-aspnet-core/

I found out my Google password had special characters, which led to the /etc/postfix/sasl_passwd not being properly read. Simply the password (long one ofc) with up/lower case characters, numbers.

I also combined the settings found here if you still have trouble:

https://documentation.wazuh.com/2.0/user-manual/manager/output-options/manual-email-report/smtp_authentication.html

https://opentodo.net/2013/03/postfix-smtp-relay-to-smtp-gmail-com/