Question

Unable to SFTP into my Fedora 33 droplet; SSH works fine

I have created a user and I am able to ssh into it using my key in my msys2 terminal just fine. I have a copy of this key with a .ppk extension to allow for FileZilla to use it as well.

Is there some setting I’m missing in the sshd_config that would cause an SFTP client to fail to connect with FileZilla’s error “No supported authentication methods available (server sent: publickey,gssapi-keyex,gssapi-with-mic)”? This must have been a recent change as I have another droplet that is running an older version of Fedora and it allows sftp without an issue.

Thanks, Jim

Show comments

Submit an answer

This textbox defaults to using Markdown to format your answer.

You can type !ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

Sign In or Sign Up to Answer

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Want to learn more? Join the DigitalOcean Community!

Join our DigitalOcean community of over a million developers for free! Get help and share knowledge in Q&A, subscribe to topics of interest, and get courses and tools that will help you grow as a developer and scale your project or business.

Hello, @jimmio92

By default, SFTP uses the SSH protocol to authenticate and establish a secure connection. Because of this, the same authentication methods are available that are present in SSH.

You can use the root username and password in order to access your droplet using sFTP. If you’re unable to access the droplet using the ssh you can also reset your password.

I will recommend you to double check these article:

https://www.digitalocean.com/community/tutorials/how-to-use-sftp-to-securely-transfer-files-with-a-remote-server

Hope that this helps! Regards, Alex

Hi @jimmio92,

How are you authenticating, is it with a password or an SSH key? By default, the DigitalOcean droplets come with passwordauthentication turned off.

You might be able SSH to your droplet because you are using an SSH KEY and not being able to use SFTP because you are using a password.

What I suggest is using your SSH key to use SFTP as well. Having said that if you are using a username different than root, you’ll need to add the SSH keys to this user’s directory.

Regards, KFSys