Unable to SSH into brand new droplet

October 2, 2014 2.4k views

I am not able to connect to the droplet via putty

I followed the article here https://www.digitalocean.com/community/tutorials/how-to-log-into-your-droplet-with-putty-for-windows-users

I get Network Error Connection timeout. I checked the ssh server status in droplet and it shows its running. I started the demo mean app on node.js but cannot access via web browser either. This is my first shot at Digital Ocean.

1 comment
  • All I do is start putty up, and enter the server ip address from the email you receive in the Hostname (or IP address) field. Leave the port at 22, and click open. (I don't select the "type 2" only as the article says. I just leave it as is.

    Make sure you don't put only the ip address in the box.

    When putty starts up enter: root for user/login when asked. For the password if you are typing it you won't see it displayed on the screen, but it is really there you just can't see it.

    You can also copy the password from the email, and when asked for your password right-click on the putty screen 1 time and hit enter.

    If you are getting Network Error Connection timeout try again. You can also right click on the very top of putty when this happens and choose restart session/connection if you know you entered everything right. If not, choose new or just close it out and try again.

    The email will come before the dropplet is finished creating usually. So you need to wait for the progress bar to complete, and I would also wait another minute or two after that before trying to login with putty. Not much longer than that though.

    Otherwise you are probably entering something wrong. Make sure you don't have any spaces in the hostname/ip field, etc.

3 Answers

Check your firewall and make sure the ssh service is enabled. Typical symptom when not enabled is you don't get a login prompt when connecting externally, but you do when connecting via the digital ocean droplet console.

check firewall is installed

sudo ufw status

if not, then install it:

sudo apt-get install ufw

then allow ssh:

sudo ufw allow ssh

This happened to me when I changed the default port from 22 to 12345. If like me, you did the same, you need to add a rule to the firewall which will allow ssh connections via the port you specified.

sudo ufw allow 12345

Fixed my issue.

Have another answer? Share your knowledge.