Question

Unable to start apache on RHEL 7

[root@ABFSTCLCGTWPA ~]# systemctl -l status httpd
● httpd.service - The Apache HTTP Server
   Loaded: loaded (/usr/lib/systemd/system/httpd.service; disabled; vendor preset: disabled)
   Active: failed (Result: exit-code) since Thu 2020-05-28 20:41:19 IST; 13min ago
     Docs: man:httpd.service(8)
  Process: 200132 ExecStart=/usr/sbin/httpd $OPTIONS -DFOREGROUND (code=exited, status=1/FAILURE)
 Main PID: 200132 (code=exited, status=1/FAILURE)

May 28 20:41:19 ABFSTCLCGTWPA systemd[1]: Starting The Apache HTTP Server...
May 28 20:41:19 ABFSTCLCGTWPA httpd[200132]: httpd: Syntax error on line 56 of /etc/httpd/conf/httpd.conf: Syntax error on line 49 of /etc/httpd/conf.modules.d/00-base.conf: Cannot load modules/mod_remoteip.so into server: /etc/httpd/modules/mod_remoteip.so: undefined symbol: apr_sockaddr_is_wildcard
May 28 20:41:19 ABFSTCLCGTWPA systemd[1]: httpd.service: main process exited, code=exited, status=1/FAILURE
May 28 20:41:19 ABFSTCLCGTWPA systemd[1]: Failed to start The Apache HTTP Server.
May 28 20:41:19 ABFSTCLCGTWPA systemd[1]: Unit httpd.service entered failed state.
May 28 20:41:19 ABFSTCLCGTWPA systemd[1]: httpd.service failed.

when i entered below comment

[root@ABFSTCLCGTWPA ~]# sudo httpd -t
httpd: Syntax error on line 56 of /etc/httpd/conf/httpd.conf: Syntax error on line 49 of /etc/httpd/conf.modules.d/00-base.conf: Cannot load modules/mod_remoteip.so into server: /etc/httpd/modules/mod_remoteip.so: undefined symbol: apr_sockaddr_is_wildcard
[root@ABFSTCLCGTWPA ~]#
Subscribe
Share

Submit an answer
You can type!ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Hi there @ksiddhesh54,

It looks like you are trying to load an apache module called mod_remoteip but there is a problem with the mod_remoteip.so file. How did you exactly install the module?

You could try to reinstall the module first and then load it in your Apache configuration.

Another thing you could do, as a quick fix, remove or comment out the line from your Apache config file so that it does not try to load it.

To do that open the /etc/httpd/conf.modules.d/00-base.conf config file on line 49 and add a # in the beginning in order to disable the module completely. After that restart Apache again.

Let me know how it goes! Regards, Bobby