Question

Unable to verify domain using DNS TXT record after adding it.

i wanted to verify my newly added domain …by adding nameserver to move it from godaddy to digital ocean and have made it live.However i wanted to verify my domain name by using TXT to my domain as suggested by google webmaster. - https://www.google.com/webmasters/verification/home?hl=en

 Add the TXT record below to the DNS configuration for mywebsite.com.

I successfully created a new TXT record under Networking and added it with my domain name.So in the DNS records table, i can see new entry as shown below -

Type	Hostname	       Value	                                                              TTL (seconds)	
 TXT         MYDOMAIN         pasted the value provided by google                      3600

But after trying to verify my domain…it fails always.Wondering where i went wrong. Kindly help.

Subscribe
Share

Submit an answer
You can type!ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

I was having this problem (Oct, 2019), and here was my solution:

Problem: I was setting the text record on the full domain. For example, I was adding the prefix “www” in the TXT record, which assigned the text record to my full domain - www.thediygolfer.com.

Solution: In the “hostname” section of Digital Ocean networking, you need to put the “@” symbol, which will assign the text record to the top level domain (i.e. “thediygolfer.com”) rather than the subdomain (i.e. “www.thediygolfer.com”).

Hope that helps someone!

Hi, I have the same problem. I am trying to assign this personal URL https://sites.google.com/s/10Q2zChTVUJ-Ro1FvAofS26AmHSaG4GJ6/p/1Dicn6c0QLV2aylDPkkmvg5nXTWtGWIGF/edit?pli=1&authuser=1

to www.wingsoverafrica.org

This is a domain that I own through Godaddy. I have added the TXT record, and the CNAME record and the A record also exists.

I have attached the screenshot of the DNS record at Godaddy. The CNAME record verifies, but the TXT record refuses to verify, so I am unable to add my custom URL. It would appear that instead of using either TXT record or a CNAME record, Google looks for a TXT record first, and if that fails to verify, it doesn’t bother with the CNAME record. This looks like sloppy programming to me.

What exactly is the issue here? I will just say that this is an extraordinarily complicated verification process, and I think Google could simplify and streamline this

Thanks

its almost close to 24 hrs but i wlll wait more one day to get this into effect.Thanks for the highlighting this. I knew this but i forgot as changes in DNS take some time.Will update after two days.Thanks for your time.

How long did you wait? You may need to wait up to 12 - 48 hours for propagation