Question

Unexpected result from answering a Linux prompt on my Droplet

As I was following the tutorial on “How To Serve Flask Applications with Gunicorn and Nginx on Ubuntu 20.04” I was prompted to install various packages, such as Certbot for setting up my SSL certificate.

When I did the following command: sudo apt install python3-certbot-nginx

I got this reply:

Need to get 1264 kB of archives. After this operation, 6657 kB of additional disk space will be used. Do you want to continue? [Y/n] Y Abort.

As you can see, the prompt was [Y/n], which made me think I need to type an uppercase Y to say yes. But when I did, the operation aborted. Very confusing. When I tried it again and used a lowercase y, it proceeded.

I will share this as a ticket, but I also want to share it in the community in case others have the same problem.


Submit an answer

This textbox defaults to using Markdown to format your answer.

You can type !ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

Sign In or Sign Up to Answer

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Want to learn more? Join the DigitalOcean Community!

Join our DigitalOcean community of over a million developers for free! Get help and share knowledge in Q&A, subscribe to topics of interest, and get courses and tools that will help you grow as a developer and scale your project or business.

Hi @Bluemont,

That is indeed very weird, thank you for sharing it!

This prompt is not actually related to your Droplet but with the packages, you’ve been installing as you’ve noticed. The Y or y symbol shouldn’t be different in outcome though. Is it possible you’ve accidentally pressed CTRL + C or another key combination to Abort the process? I’ve tried to replicate this but so far to no avail :/

Hello,

I have jus tested this on Ubuntu 21.10 and it seems to have worked with both capital and lowercase y.

What is the exact Ubuntu version that you have? You can check this with:

cat /etc/os-release

Also, do you get any specific errors when you try with an uppercase Y or does it just stop?

Best,

Bobby