Unsecured Wordpress after Certbot SSL

I created a droplet with a one-click Wordpress installation. I set up the domain and pointed the DNS in Namecheap. After that everything looks like it is working when checking the domain, it would take me to the Wordpress site. As a final step, I created the Certbot certificate and it goes through successfully, but then after doing that my website becomes unsecured because: NET::ERR_CERT_COMMON_NAME_INVALID

I’ve tried this a few times today with the same result. Am I missing a step somewhere?

Submit an answer

This textbox defaults to using Markdown to format your answer.

You can type !ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

Sign In or Sign Up to Answer

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Want to learn more? Join the DigitalOcean Community!

Join our DigitalOcean community of over a million developers for free! Get help and share knowledge in Q&A, subscribe to topics of interest, and get courses and tools that will help you grow as a developer and scale your project or business.

Hello Samcro

Can you please check the SSL for your domain using the following link:

It will show you if there is an installed SSL Certificate on your server for the domain name. Also since you’ve mentioned that the DNS was recently updated, keep in mind that there might be DNS cache as the DNS needs some time in order to fully propagate, usually it’s faster but this might take up to 24 hours.

If the domain does not have a SSL Certificate installed and you can see that it’s loading from your droplet you can check the apache/nginx virtual host for the domain name and make sure everything is set correctly.

The other option will be to issue/install the SSL using certbot again. This article is really good:

Let me know how it goes.