Hello, I had successfully installed rocketchat using DigitalOcean and it was up and running. I then wanted to use the direct message between multiple groups feature and thought that I needed to update rocket.chat to use the multiple groups feature (still don’t know if I actually need to…). I opened up terminal, logged into root user and typed “rocketchatctl update” per the instructions, and it seemed to work but then it said it could not connect to the server and now, I cannot get back in (it says “bad gateway”). Any help is seriously appreciated–I am new to rocket.chat and unfortunately do not have much experience. I need it up and running asap :(

This is what I see when I type sudo systemctl status rocket.chat service

● rocketchat.service - The Rocket.Chat server
Loaded: loaded (/lib/systemd/system/rocketchat.service; enabled; vendor preset: enabled)
Active: failed (Result: exit-code) since Fri 2020-06-05 17:34:33 UTC; 30s ago
Process: 12842 ExecStart=/usr/bin/node /opt/Rocket.Chat/main.js (code=exited, status=1/FAILURE)
Main PID: 12842 (code=exited, status=1/FAILURE)

Jun 05 17:34:32 TC-Education-for-Thinking systemd[1]: Started The Rocket.Chat server.
Jun 05 17:34:33 TC-Education-for-Thinking rocketchat[12842]: Meteor requires Node v12.0.0 or later.
Jun 05 17:34:33 TC-Education-for-Thinking systemd[1]: rocketchat.service: Main process exited, code=exited, status=1/FAILURE
Jun 05 17:34:33 TC-Education-for-Thinking systemd[1]: rocketchat.service: Failed with result ‘exit-code’.

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

×
1 answer

Nevermind! Problem fixed! I found the answer here for anyone who encounters the same problem: https://forums.rocket.chat/t/upgrading-to-3-0-0/5892/7

Submit an Answer