Updating to Wordpress 3.8 Failed on Droplet Image that Comes with Wordpress Pre-installed.

December 18, 2013 7.5k views
Hi, Recently I tried to update the Droplet I've installed from the image with wordpress installed, to version 3.8, but failed, below is the error messages I received: Downloading update from https://wordpress.org/wordpress-3.8-new-bundled.zip… Unpacking the update… The update cannot be installed because we will be unable to copy some files. This is usually due to inconsistent file permissions.: wp-admin/includes/update-core.php Installation Failed May I know whether your side would be able to help? Or it's beyond your responsibilities? Thanks. Cheers, Jenson
16 Answers
@admin: Run the follownig command as well, does that fix it?
sudo chown -R www-data /path/to/wordpress
Make sure all of the files & directories in your WordPress web directory is owned by www-data:www-data. To check, execute:
ls -la /path/to/WordPress/Installation/

and make sure there is no root:root sprinkled in there.
usermod -a -G www-data wordpress 
should fix it.

Let me know if that works.
Hi Kamal Nasser, it didn't work.

Hi Pablo, I execute the command you've given, however, it returned this error message:

Cannot Access /path/to/WordPress/Installation/
You must replace /path/to/WordPress/Installation/ with the actual path to your wordpress installation for the command to work.
Running 'usermod -a -G www-data wordpress' doesn't fix it.
changing the owner to www-data with sudo chown worked great. thanks!
I'm in need of additional help with this. I'm familiar with dev on sites/wordpress but super new to digitalocean. I can access the console but unable to figure out what my installation path is to update. What part do I include? I've tried every combo so far and I'm still receiving "No such file or directory"
@Lindsey: I assume you're using nginx, can you pastebin your nginx virtualhost config?
I have this how do I change to www-data www-data because at the moment i am seeing this

-rwxr-xr-x 1 www-data root 2359 Sep 12 06:57 wp-load.php
-rwxr-xr-x 1 www-data root 31909 Dec 12 21:37 wp-login.php
I had this problem and changing the owner on the wordpress folder worked for me

sudo chown -R www-data /path/to/wordpress (in my case is was /home/wordpress)
This helped also with the failure when trying to upgrade to 3.8.1:

sudo chown -R www-data /path/to/wordpress (in my case is was /home/wordpress)
Yes! This worked for me...

sudo chown -R www-data /path/to/wordpress

mine was a bit different... sudo chown -R www-data/home/wordpress/public_html
Thanks so much! Finally got this to work!

Just in case... make sure there's a space between 'www-data' and 'path to wordpress'

Mine was:
sudo chown -R www-data /home/wordpress
This worked like charm. :)

sudo chown -R www-data /var/www/
Have another answer? Share your knowledge.