wikro
By:
wikro

Upgrade from Freebsd from 10.3 to 11

January 19, 2017 1.4k views
DigitalOcean FreeBSD

Hello,

I'v tried to upgrade my Freebsd 10.3 droplet to Freebsd 11, but after the last reboot (after installing the new kernel, rebuilding all ports and deleting the old system libraries using freebsd-update) the droplet doesn't boot. Instead I get the error message "/etc/rc: ERROR: USAGE: loadrcconfig name", and I cannot for the life of me figure out why this is happening.

I'd rather not have to put up at new droplet with Freebsd 11 as it would take much longer to get the new droplet configured the way my current one is than to upgrade.

Regards, W

3 Answers

@wikro

I don't use FreeBSD much, though I did a little research and what you're experiencing pops up quite a bit. Some posts have solutions, some not so much.

What I did find was one user who actually performed and update + upgrade from 10.x to 11.x. You can check that post out here.

When you went to upgrade, did you first run:

freebsd-update fetch

then

freebsd-update install

and finally

freebsd-update -r 11.0-RELEASE upgrade

to handle the upgrade? If not, that may be the issue. From what I'm reading, FreeBSD doesn't perform updates & upgrades with a single command (much like how Ubuntu handles things), so you'll need to perform each step individually, otherwise you may end up with the same results.

That said, what I recommend doing, if you don't or haven't already, is always take a snapshot of your droplet before you perform major updates or upgrades. Doing so will allow you to quickly revert back to the previous state should something like this happen.

@wikro

No problem -- What I would recommend doing at this point, if you've not already, is to submit a ticket through the DigitalOcean Control Panel and see if the support team can lend a hand.

If they Droplet won't boot at all, even when attempting to access it from the console provided through the CP, they should be able to help more than I could here since I don't have physical access to the core machine your droplet is on (I just do my best to help here in the community).

I don't really like telling members to submit a ticket, though when it's something that's physically out of my control, that's the best course of action.

  • Thank you again for your reply. I'll try to submit a ticket as well.

    Have a nice day.

I just tried to do the same upgrade. I got a bootable droplet, but non-fuctional. I couldn't ssh into it. Basically I'm just bumping this message hoping someone else is watching. I don't think this is really a job for Digital Ocean to investigate every 10.3 to 11 upgrade. Certainly not at the prices these droplets cost. But if someone has success doing the upgrade, I hope they post what they did.

Edit: I see a post indicating there is a freebsd 11 droplet now. I will try this "alternative" I wrote:

As an alternative, if Digital Ocean sets up a fresh FreeBSD 11 droplet, I would get another droplet for a while , getting my site going on it, then once it works, move that snapshot back my regular IP. I don't see this upgrade going smoothly enough just take the server down a few hours and get it running the upgrade promptly

Have another answer? Share your knowledge.