Question

Upgraded to nginx 1.4.4 from 1.1.9 (and messed with Postfix) - now WordPress site is getting a 403 error

  • Posted on February 8, 2014
  • jb5531Asked by jb5531

I’m not sure if it was Postfix that caused this or upgrading to a newer nginx. A few bad things happened along the way probably, so I’m not sure if this has had any effect.

I had my server working with the updated nginx 1.4.4 but then I started messing with Postfix, changed my droplet name to be mail.domainname.com so that it would work (according to DigitalOcean’s tutorials). I also did a apt-get update, apt-get upgrade since my server was telling me i had upgrades and some of them were security upgrades. This installed Apache, which I promptly removed.

Anyway, I’m kind of new to this and I don’t know why this could be happening. I get my IP address to come up with nginx, ipaddress/info.php causes the info.php file to download to my machine for some reason, and my setup WordPress site is getting a 403 error.

I checked that www-data had the permissions for all of the directories - getting close to just starting over with this as it’s just a test site I’m working with at this point. Can anyone help?


Submit an answer

This textbox defaults to using Markdown to format your answer.

You can type !ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

Sign In or Sign Up to Answer

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Want to learn more? Join the DigitalOcean Community!

Join our DigitalOcean community of over a million developers for free! Get help and share knowledge in Q&A, subscribe to topics of interest, and get courses and tools that will help you grow as a developer and scale your project or business.

Can you pastebin your server block?

Hi Pablo - I do have a server block and I just changed it to allow the site to come up, but it’s confusing because it’s different than what I needed before. Specifically, before I had: <br>root /usr/share/nginx/www; <br> <br>and to make it work, almost correctly (wp-admin doesn’t seem to work, need to use wp-login.php): <br>root /var/html/mydomain.com/public_html; <br> <br>Now, that’s a pretty big difference because before I did not need to be specific and the directory resolved automatically to my WordPress install public_html directory. Not exactly sure what’s going on. <br> <br>I also made sure to symlink the sites-available to sites-enabled to make this work. <br>

Do you have a server block in <code>/etc/nginx/sites-enabled/</code> for your WordPress site?