As the title says. I have just tried, a new fresh Droplet, with Debian 9.5, a new fresh Windows 10 1803 x64 installation. TCP uploads, SCP, SFTP, HTTPS, etc, are extremely slow, like 5Mbps.

It’s not my internet connection, it’s not any CPU/RAM/Disk bottleneck, it’s not my latency or connection to DO’s LON servers, it’s not any traceroute problem, it’s not anything I installed because everything is vanilla.

What’s happening here?

Digital Ocean support is not listening at all and haven’t been able to fix the issue in the past 3 days.
If I use Debian 9 on the same Windows 10 computer where I have the problem, everything’s fine, upload speed is as far as it can go. So it’s not my computer either. This problem also shows up on other computers with Windows 10. Can anyone reproduce this problem? Download speeds from Droplet to W10 are ok.

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

×
10 answers

Some testing:

Uploading 143 MB file through SFTP, from Windows 10, to new Droplets:

Ubuntu 16.04.4 x64
·Kernel: 4.4.0-131
·Min speed: 500 KB/s
·Time: 4m7s

Ubuntu 18.04 x64
·Kernel: 4.15.0-30
·Min speed: 3.5 MB/s
·Time: 38s

Debian 8.10 x64
·Kernel: 3.16.0-5
·Min speed: 3.5 MB/s
·Time: 38s

Debian 9.3 x64
·Kernel: 4.9.0-7
·Min speed: 490 KB/s
·Time: 4m37s

This is huge, Ubuntu 16.04.x and Debian 9.x which are the default OSs for Ubuntu and Debian Droplets are the slowest. Are all Windows clients/users having this upload limit issue to Droplets??

More tests, same as before:

Uploading 143 MB file through SFTP, from Windows 10, to new Droplets:

FreeBSD 11.2-RELEASE
Version: r335510
Min speed: 4.5 MB/s
Time: 26s

Fedora 28 x64
Kernel: 4.16.3-301
Min speed: 8 MB/s
Time: 15s

CentOS 7.5 x64
Kernel: 3.10.0-862
Min speed: 1.5 MB/s
Time: 1m10s

Same issue here. Getting 10MB/s. I have a 1 gigabit fibre connection.

The connection from my home to windows azure(container service) is faster than from digital ocean…it really sucks.

If this services use some kind of filter to slowdown ftp or http upload from windows 10, its a very good reason for change the provider. Vultr.com Works Fine .. i use $40 Ubuntu Droplet with 8gb ram 4 core here at DO and its to slow is you want upload files. Incredible.

Any help on this? I’m noticing also slow download. between 500 - 1500kb/s which is terrible

The download speeds are fine, they start slow but end up where they need to be over time. My problem is the upload speeds, Ive literally changed to new ISP three times because I thought it was their fault. I just found this post and I’m now starting to realize that its a DigitalOcean bottleneck for Uploading to the server. I am running Windows10. The upload speeds are poor with both SSH Terminal or SFTP Filezilla/WinSCP.

I’m not sure why DigitalOcean wouldn’t consider looking into this as they are very good at everything else they have done up until now, it would be in their best interest to investigate as its their service they providing that is faulty.

I cant believe I literally burnt three ISPs because of poor ftp and ssh upload speeds before finding this post. EEEK. I hope DigitalOcean get on top of this :D

Hi, OP here.
I still have this problem after a year.
DigitalOcean doesn’t care about it.
If I ever need to upgrade I’ll go with another company.
This is a problem. Imagine you have a website were people can upload videos, photos, or files, but most of them use Windows 10 at home or office. Even if they had 1Gbps upload speed with their ISP the upload speed to a DigitalOcean droplet would be a fraction of that, for no good reason. Again, this problem happens independently of the protocol used, it affects all TCP connections.

I’m still seeing this as well. 12 - 20 KiB/s from Windows machines in my house, 3 - 5 MiB/s from Linux machines. Tried multiple machines and different types of software, it’s applying not just to SFTP/SSH but to HTTP and everything. Windows users can’t properly browse sites hosted on my Ubuntu droplet, it’s legitimately unusable.

I’m having similar problems.

From my Windows PC:

D:\Users\saadbruno\Desktop>iperf3 -c <droplet IP>
Connecting to host <droplet IP>, port 5201
[  4] local <local windows ip> port 53859 connected to <droplet IP> port 5201
- - - - - - - - - - - - - - - - - - - - - - - - -
[ ID] Interval           Transfer     Bandwidth
[  4]   0.00-10.00  sec  1.88 MBytes  1.57 Mbits/sec                  sender
[  4]   0.00-10.00  sec  1.72 MBytes  1.44 Mbits/sec                  receiver
iperf Done.

From my Windows Laptop:

C:\Users\Saad>Downloads\iperf-3.1.3-win64\iperf-3.1.3-win64\iperf3.exe -c <droplet IP>
Connecting to host <droplet IP>, port 5201
[  4] local <local windows ip> port 60900 connected to <droplet IP> port 5201
- - - - - - - - - - - - - - - - - - - - - - - - -
[ ID] Interval           Transfer     Bandwidth
[  4]   0.00-10.01  sec  2.88 MBytes  2.41 Mbits/sec                  sender
[  4]   0.00-10.01  sec  2.72 MBytes  2.28 Mbits/sec                  receiver
iperf Done.

If I try form my Raspberry Pi, which is in the same network, i get this:

saad@saadraspi:~ $ iperf3 -c <droplet IP>
Connecting to host <droplet IP>, port 5201
[  5] local <raspberry pi ip> port 60882 connected to <droplet IP> port 5201
- - - - - - - - - - - - - - - - - - - - - - - - -
[ ID] Interval           Transfer     Bitrate         Retr
[  5]   0.00-10.00  sec  74.6 MBytes  62.6 Mbits/sec  343             sender
[  5]   0.00-10.00  sec  72.5 MBytes  60.8 Mbits/sec                  receiver
iperf Done.

Notes:

  • If I boot Ubuntu on the same windows PC as the first test, I also get good speeds.

  • Seems to affect TCP only. If I run through UDP I get this:

    D:\Users\saadbruno\Desktop>iperf3 -u -b 100M -c <droplet IP>
    Connecting to host <droplet IP>, port 5201
    [  4] local <windows ip> port 59251 connected to <droplet IP> port 5201
    - - - - - - - - - - - - - - - - - - - - - - - - -
    [ ID] Interval           Transfer     Bandwidth       Jitter    Lost/Total Datagrams
    [  4]   0.00-10.00  sec   118 MBytes  99.1 Mbits/sec  0.273 ms  22/2206 (1%)
    [  4] Sent 2206 datagrams
    iperf Done.
    

So:
1 - It’s not my ISP, cause I get good speeds from my Raspberry Pi on the same network

2 - It’s not my PC, cause another Windows installation (on my laptop) gets poor speeds as well.

2b - It’s not my network card, cause if I boot on Ubuntu on the same machine, I get good speeds

3 - It’s not an iperf problem, cause I get similar speeds through sftp, and other TCP connections.

So I can think 2 things:
Either something is wrong with the DigitalOcean Droplet, or something is wrong with Windows (maybe the windows network drivers? But I did install / update the driver directly from Realtek and the problem still persists).

Submit an Answer