Question

Uploading docker image fails repeatedly

Suddenly I started getting the following error:

23:52:32 => Uploading the built Docker image to the container registry
23:53:37 exit status 246
23:53:37 => Uploading...
23:54:49 exit status 246
23:54:49 => Uploading...
23:56:01 exit status 246
23:56:01 => Uploading...
23:57:13 exit status 246
23:57:14 => Uploading...
00:00:38  ! Image upload failed
00:00:38 Reusing layers from image <registry-uri>
00:00:38 Adding layer 'heroku/python:profile'
00:00:38 Adding 1/1 app layer(s)
00:00:38 Adding layer 'launcher'
00:00:38 Adding layer 'config'
00:00:38 Adding label 'io.buildpacks.lifecycle.metadata'
00:00:38 Adding label 'io.buildpacks.build.metadata'
00:00:38 Adding label 'io.buildpacks.project.metadata'

00:00:38 ERROR: failed to export: failed to write image to the following tags: [<image>: Head ..... dial tcp: lookup fra1.digitaloceanspaces.com on 10.245.0.10:53: no such host]

I reverted the code for which the build failed the first time with this message (even though the code changes should have nothing to do with this error) and I still keep getting the same error.

Anyone has an idea what’s going on? I’m not able to deploy my app anymore.


Submit an answer

This textbox defaults to using Markdown to format your answer.

You can type !ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

Sign In or Sign Up to Answer

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Want to learn more? Join the DigitalOcean Community!

Join our DigitalOcean community of over a million developers for free! Get help and share knowledge in Q&A, subscribe to topics of interest, and get courses and tools that will help you grow as a developer and scale your project or business.

Same issue for me today

Same here…

[2022-02-19 23:31:38] ERROR: failed to export: failed to write image to the following tags: [: HEAD unexpected status code 401 Unauthorized (HEAD responses have no body, use GET for details)]


[2022-02-19 23:31:38] command exited with code 246

same issue here