Uploading Web2py App 413 Request Entity Too Large

November 21, 2015 2.4k views
Nginx

Try to upload web2py app to be depolyed and getting 413 Request Entity Too Large.

The file is 1.5MB, can can I get around this

2 Answers

@jackiewalkabout

For NGINX, you'd need to make sure your nginx.conf file sets the client_max_body_size. By default, this is not set, so you'd need to login to the CLI and load:

/etc/nginx/nginx.conf

... and then add:

client_max_body_size = 2M;

... of course, you can set 2M to any realistic size; for example, 8M, 16M, etc.

This directive should appear before the include directive that loads your website config, like so:

client_max_body_size = 2M;

include /etc/nginx/conf.d/*.conf;
include /etc/nginx/sites-enabled/*;

Note: You may or may not have both of the above include directives defined in your nginx.conf file. If not, don't worry, this is simply an example to show that it should appear the include directive.

Good advice for @jackiewalkabout , but I suggest not adding the = to client_max_body_size. If will fail. :D

client_max_body_size $size;

Have another answer? Share your knowledge.