Using DO managed kubernetes cluster with helm chart stable/prometheus results in some node_exporters being unreachable.

Posted December 7, 2018 3.8k views

I have three nodes in the cluster. Prometheus pods (which include server, alertmanager, nodeexporter etc) start just fine. Unfortunately 2 of the 3 nodeexporters cannot be reached. This seems like it must be some issue with flannel, but I don’t know how to begin to debug this.

Prometheus itself (the dashboard) reports the error “context deadline exceeded” for the 2 node_exporter pods. When I create a single “curl” pod for curling ClusterIPs, the curl command hangs when trying to connect to these two.

So the question is how does one verify that flannel is functioning correctly?


helm install –name prometheus-service stable/prometheus
kubectl port-forward prometheus-service-server-<id> 9090
http://localhost:9090/targets (view in browser)

And see that some (perhaps all but one) of the node_exporter pods report “context deadline exceeded”.

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Submit an Answer
6 answers

Make sure to open tcp/9100 from in the DO firewall panel of your cluster.

You might also have noticed that prometheus fails to get kubelet metrics. Watch this question for updates:

I opened port 9100 via the droplet networking control panel, and it now seems to work, and it looks like because there’s one firewall config for the cluster, that is applied to subsequent nodes that are spun up. The same sources as the rest of the k8s rules can be used.

Would be curious to see if this worked for you.

I am wondering if there is something incorrect about how my nodes are set up or I just don’t understand how the networking is supposed to work.

1) Get a listing of the nodes:
kubectl get nodes -o wide

2) Create a pod that can curl:
kubectl run curl –image=radial/busyboxplus:curl -i –tty

3) Try curling the internal-ip that is listed from #1.

The result is that the curl pod can only curl the node that it is apart of. Is this how this is supposed to work? Curling any other node’s internal-ip results in curl hanging.

I’m having this same problem. @guy1234 , I also found your GitHub issue (, did you ever find a resolution / workaround for this?

FYI i was able to fix this issue by adding the port 9100 in the k8s firewall and addresses:

I ran into the same issue. The reason for this is probably that the node-exporter are configured with hostNetwork: true. This is required to be able to scrape some networking metrics but also mean that it runs in the host network namespace. It seems that this traffic is not going through Cilium but directly via the private network. Therefore we need to add a firewall rule as @manelpb already stated. Nevertheless you can leave out (I believe it’s the load balancer subnet), so allowing and as source ip range on port 9100 works.