Question

Using Zoho mail, PHP mail() goes to spam.

Okay, I’m a very newbie to Linux servers.

I am running LAMP stack on my droplet. All the mail system is powered by Zoho mail (some kind like Google Apps).

I wrote a PHP web app, and the e-mail sent from mail() goes directly to spam in Gmail.

Here is the information obtained from Gmail when I send my Email from the PHP web app:

Delivered-To: t******@gmail.com
Received: by 10.202.168.206 with SMTP id r197csp2640062oie;
        Mon, 1 Feb 2016 01:03:13 -0800 (PST)
X-Received: by 10.107.131.155 with SMTP id n27mr4882881ioi.132.1454317393436;
        Mon, 01 Feb 2016 01:03:13 -0800 (PST)
Return-Path: <www-data@srakrn.com>
Received: from srakrn.com ([128.199.248.75])
        by mx.google.com with ESMTPS id u4si13948179igr.88.2016.02.01.01.03.12
        for <t******@gmail.com>
        (version=TLS1_2 cipher=ECDHE-RSA-AES128-GCM-SHA256 bits=128/128);
        Mon, 01 Feb 2016 01:03:13 -0800 (PST)
Received-SPF: neutral (google.com: 128.199.248.75 is neither permitted nor denied by best guess record for domain of www-data@srakrn.com) client-ip=128.199.248.75;
Authentication-Results: mx.google.com;
       spf=neutral (google.com: 128.199.248.75 is neither permitted nor denied by best guess record for domain of www-data@srakrn.com) smtp.mailfrom=www-data@srakrn.com
Received: from srakrn.com (localhost [127.0.0.1])
by srakrn.com (8.14.4/8.14.4/Debian-4.1ubuntu1) with ESMTP id u1193BBg002012
	for <t******@gmail.com>; Mon, 1 Feb 2016 04:03:11 -0500
Received: (from www-data@localhost)
	by srakrn.com (8.14.4/8.14.4/Submit) id u1193B54002011;
	Mon, 1 Feb 2016 04:03:11 -0500

The line “Received: from srakrn.com (localhost [127.0.0.1])” made me think I’m configuring something very, very wrong.

I’ve tried changing the host name to srakrn.com, and tried editing /etc/hosts to make sure the IP points to my domain. What can I do next?


Submit an answer

This textbox defaults to using Markdown to format your answer.

You can type !ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

Sign In or Sign Up to Answer

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Want to learn more? Join the DigitalOcean Community!

Join our DigitalOcean community of over a million developers for free! Get help and share knowledge in Q&A, subscribe to topics of interest, and get courses and tools that will help you grow as a developer and scale your project or business.

You should add - verify DKIM and SPF with your domain name in Zoho mail app settings. This gives mail exchange verifies and chances of getting into inbox is very high (unless there are many links, many spam keywords)