I’ve recently upgraded to Ubuntu 20.04.1 LTS and it tells me that mySQL 8 didn’t update successfully. When I try to follow steps to “Fix” the error I keep getting the same error:

dpkg: error processing package mysql-server (–configure):
dependency problems - leaving unconfigured
Errors were encountered while processing:
mysql-server-8.0
mysql-server

Please help!

1 comment
  • FYI - I’ve tried using
    apt install mysql-server
    but that was unsuccessful

    I’ve also tried to install the dependency packages:

    apt-get -f install
    

    and stil get the same error

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

×
1 answer

Hi, @davidboudia
You can use the following to remove any redundant dependency issues and install a functioning MySQL package

Note: I will strongly recommend you to take a snapshot of the droplet before executing any commands. Further troubleshooting the issue can cause issues with other services and it’s good to have a copy of the current state of the droplet.

sudo apt-get clean
sudo apt-get purge mysql*
sudo apt-get update
sudo apt-get install -f
sudo apt-get install mysql-server-5.7
sudo apt-get dist-upgrade

This should sort the issue for you. Let us know how it goes.

Hope that this helps!
Regards,
Alex

  • Hi Alex,

    I tried these or similar and kept getting the same error message. I figured out what the problem was - there is was an erroneous sql-mode that I was using

    NO_AUTO_CREATE_USER
    

    in the mysql config file. After I removed that, i was able to complete the mysql installation and everything seems to be running fine. Thanks for the response.

    • Hi, @davidboudia

      I’m glad you’ve sorted this! Also thank you for sharing what the issue was and how you’ve sorted it as other users can find this useful if they run into the same problem and open this question.

      Regards,
      Alex

Submit an Answer