Vagrant does does not work with DO

config.vm.provider :digital_ocean do |provider| provider.ssh.private_key_path = “~/.ssh/id_rsa” provider.token = “(****************************************************************)” provider.image = “ubuntu-14-04-x64” provider.region = “ams1” provider.size = “1gb” provider.private_networking = true provider.backups_enable = true


I tried to bring up a droplet with the shown vagrant config but when I run it I get this vagrant up --provider digital_ocean Bringing machine ‘default’ up with ‘digital_ocean’ provider… There was an issue with the request made to the Digital Ocean API at:

Path: /v2/droplets URI Params: {}

The response status from the API was:

Status: 401 Response: {“id”=>“translation missing:”, “message”=>“Unable to authenticate you.”}

I have the most recent version of Vagrant and v 0.7.0 of the DO plugin

Show comments

Submit an answer

This textbox defaults to using Markdown to format your answer.

You can type !ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

Sign In or Sign Up to Answer

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Want to learn more? Join the DigitalOcean Community!

Join our DigitalOcean community of over a million developers for free! Get help and share knowledge in Q&A, subscribe to topics of interest, and get courses and tools that will help you grow as a developer and scale your project or business.


the plugin now use API v2, so check if your Vagranfile have:

provider.token = ‘YOUR TOKEN’

Sample code:

Vagrant.configure('2') do |config|

  config.vm.provider :digital_ocean do |provider, override|
    override.ssh.private_key_path = '~/.ssh/id_rsa' = 'digital_ocean'
    override.vm.box_url = ""

    provider.token = 'YOUR TOKEN'
    provider.image = 'ubuntu-14-04-x64'
    provider.region = 'nyc2'
    provider.size = '512mb'