Question

version `GLIBC_2.28' not found after running a force/build/deploy on my existing Apps

I have a few static websites deployed using Digital Ocean’s App and all of them suddenly (upon rebuild/redeploy) failed to deploy due this error.

42:44] Project contains yarn.lock, using yarn
[2022-04-19 21:42:44] Warning: both yarn.lock and package-lock.json were found, using yarn.
[2022-04-19 21:42:44] Installing node_modules using yarn (from yarn.lock)
[2022-04-19 21:42:44] Running yarn install
[2022-04-19 21:42:44] 
[2022-04-19 21:42:44] node: /lib/x86_64-linux-gnu/libc.so.6: version `GLIBC_2.28' not found (required by node)

This only happened today.

Are there any issues with DO infrastructure today?


Submit an answer

This textbox defaults to using Markdown to format your answer.

You can type !ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

Sign In or Sign Up to Answer

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Accepted Answer

Hey, it seems that the plaform app is now installing node 18 by default and creating problems in apps that don’t run on that version.

Specifying my node version in package.json solved the problem.

"engines": {
 "node": "17.1.0",
}

Hope it helps, Happy coding.

Want to learn more? Join the DigitalOcean Community!

Join our DigitalOcean community of over a million developers for free! Get help and share knowledge in Q&A, subscribe to topics of interest, and get courses and tools that will help you grow as a developer and scale your project or business.

Hey, I got the exact same problem, I checked the recommended node version and as of today it is 16.14.2 so I added the node version in the package.json under “engines” as "engines": { "node": "16.14.2" },

and it worked, hope your problem is also the same and solved by this addition, best!

Hi @alvinpermelonareyes,

Upon reading more about the problem, I couldn’t find a direct solution to the Problem.

What has been suggested on multiple occasions is :

  1. rm -rf node_modules/
  2. yarn install

Having said that, that’s a drastic measure which I’ll recommend doing ONLY after you have created a Snapshot of your Droplet. Another solution would be setting the node version to a lower one like :

  1. "engines": {
  2. "node": "17.0.0",
  3. }

Thank to @joniEAHH for the above suggestion.

Additionally, I found this which can help you out - GLIBC_2.28 Error