Question

Virtual hosts not working. Getting a redirect to the default apache page.

Hi! i made a doplet to deploy my wordpress applications and i create a virtual host with apache2. So, this is my .conf at /etc/apache2/sites-available/revistaestilooff.com.br.conf :

# Added to mitigate CVE-2017-8295 vulnerability
UseCanonicalName On

<VirtualHost *:80>
        ServerAdmin mikhaelipcn@gmail.com

        ServerName revistaestilooff.com.br
        ServerAlias www.revistaestilooff.com.br

        DocumentRoot /var/www/estilo_off

        <Directory /var/www/estilo_off>
            Options FollowSymLinks
            AllowOverride All
            Require all granted
        </Directory>

        ErrorLog ${APACHE_LOG_DIR}/error.log
        CustomLog ${APACHE_LOG_DIR}/access.log combined
</VirtualHost>

But, when i type the domain in to the browser, i see the default page at /var/www/html. I really dont know what i miss ):

Subscribe
Share

found a solution but still not understanding…

i have this file created at /etc/apache2/sites-enabled:

000-default-le-ssl.conf

which points to the revistaestiloof.com.br domain but with the wrong documentRoot and directory.

so i change that and its work now! but why the apache is using this file instead revistaestilooff.com.br.conf ?


Submit an answer
You can type!ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Hello, @mikhaelipcn

You can check this two tutorials:

https://www.digitalocean.com/community/tutorials/how-to-install-wordpress-with-lamp-on-ubuntu-18-04

and also:

https://www.digitalocean.com/community/tutorials/how-to-install-the-apache-web-server-on-ubuntu-18-04

One thing to keep in mind is that /etc/apache2/sites-available/

directory where per-site virtual hosts can be stored. Apache will not use the configuration files found in this directory unless they are linked to the sites-enabled directory. Typically, all server block configuration is done in this directory, and then enabled by linking to the other directory with the a2ensite command.

Basically you can create a symlinks like this:

ln -s /etc/apache2/sites-available/domain.com /etc/apache2/sites-enabled/domain.com

Hope this helps.

Regards, Alex