Question

virtual hosts problem on ubuntu 12.4

Hi,

I am fairly new to this, so I probably missed something obvious.

I have a ubuntu 12.4 apache2 setup. I have two sites running, they are working fine. But when I try to set up a third one, the second site gets redirected to the third. If I set up a fourth it gets redirected to the last. My vhost config are all like:

<VirtualHost *:80>
ServerAdmin webmaster@localhost

DocumentRoot /var/www/generationalbator/public_html
ServerName www.generationalbator.be
Serveralias generationalbator.be
Serveralias www.generationalbator.be

ErrorLog /var/www/generationalbator/logs/error.log
Loglevel warn
CustomLog /var/www/generationalbator/logs/access.log combined

<Directory /var/www/generationalbator/public_html>
	AllowOverride All
	Order allow,deny
	allow from all
</Directory>

</VirtualHost>

Any ideas?


Submit an answer

This textbox defaults to using Markdown to format your answer.

You can type !ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

Sign In or Sign Up to Answer

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Want to learn more? Join the DigitalOcean Community!

Join our DigitalOcean community of over a million developers for free! Get help and share knowledge in Q&A, subscribe to topics of interest, and get courses and tools that will help you grow as a developer and scale your project or business.

Glad it’s solved! Having separate files is not an issue, that’s how I do it, I’m thinking maybe one of the configs wasn’t enabled? Never mind though!

solved. I put them in one file, ran a2ensite and it functions!

Hi,

are the virtual hosts stored in separate files in the sites-available directory? Have you run a2ensite on all configs?

Are you able to post all three virtual host files?