Question

virtualmin+nginx php conf??

Hi! I know it’s a recursive question but with virtualmin the conf is diferent: I’ve an ubuntu droplet with virtualmin and nginx. How can I configure the .php? In etc/nginx/sites-available/domain the conf is: location ~ .php$ { try_files $uri =404; fastcgi_pass unix:/var/php-nginx/13931827922062.sock/socket;
}

And I’ve seen that exists :/var/php-nginx/13931827922062.php.pid But i’ve always have the error: 25407#0: *1 connect() to unix:/var/php-nginx/13931827922062.sock/socket failed (2: No such file or directory)…upstream: “fastcgi://unix:/var/php-nginx/13931827922062.sock/socket:”

I’ve tried fastcgi_pass 127.0.0.1:9000; fastcgi_pass unix:/var/run/php5-fpm.sock; I’ve seen that in php.ini is cgi.fix_pathinfo = 0;… bat always i 've error 502 Bad gateway in nginx.

Any suggestions? thanks!

Show comments

Submit an answer

This textbox defaults to using Markdown to format your answer.

You can type !ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

Sign In or Sign Up to Answer

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Want to learn more? Join the DigitalOcean Community!

Join our DigitalOcean community of over a million developers for free! Get help and share knowledge in Q&A, subscribe to topics of interest, and get courses and tools that will help you grow as a developer and scale your project or business.

I got this error too. I googled and found no solution. Is it only two of us having this problems? I dont know how efficient you solved the problems but in my case, I just had to start php-fgi service… <br> <br>here is example: <br> <br>my domain: example.com <br>so, what I need to run is, <br> <br>service php-fcgi-example-com start <br> <br>and my website back to online… I dont know why this service stop on its own.

Thanks, Andrew!, the problem is /etc/php5/fpm/pool.d/www.conf doesn’t exist, virtualmin must install it in another path… <br>I’ve installed package php5-fpm, all with usual paths, changed the listen value and all right now.

What is the “listen” value in “/etc/php5/fpm/pool.d/www.conf” It should match what is in fastcgi_pass.