I’ve been using VNC viewer to connect to my Ubuntu server desktop. It was working fine one minute then disconnected and now I get an message saying the target machine actively refused my connection.

Nothing changed on the server - this just started happening and I’ve no idea why.

Thanks for any help.

  • Have you reviewed your VNC server logs for any indication as to what is occurring? A message saying connection refused could likely mean that the VNC service is no longer running.

  • I think I’ve found the VNC log. There’s a load of stuff in there, most of which seems to be a repeat of the following..

    (nm-applet:3821): WARNING **: asyncgottype: could not read properties for /org/freedesktop/NetworkManager/ActiveConnection/31: Rejected send message, 3 matched rules; type=“methodcall”, sender=“:1.143” (uid=1000 pid=3821 comm=“nm-applet ”) interface=“org.freedesktop.DBus.Properties” member=“Get” error name=“(unset)” requestedreply=“0” destination=“org.freedesktop.NetworkManager” (uid=0 pid=958 comm=“NetworkManager ”)

    I’m a fairly new Linux user so this is a learning curve - any advice appreciated.

  • I’ve just created a new Droplet and re-configured everything again - same error!

  • I am having the same problem , managed to solve the issue of connection refused ?

  • Did you use an SSH key instead of just a password?

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Submit an Answer
1 answer

I gave up actually - haven’t tried since…just been using Putty. If you find anything out let me know :)

  • I was having problems and killed it with vncserver -kill :1

    Restarted with vncserver and I was up again.

    In a similar question someone recommended x2go as being a better solution.