Question

VNC Gray Screen Ubuntu 14.04

  • Posted May 3, 2014

Hi,

I have been trying to follow some tutorials to get the VNC server running. All that the result currently is that I get a gray screen. This seems to be in line with what other users are experiencing as I read through some fora. Has a solution for this been created already? Would be great to see if there is an update for this. Also, don’t really know if it has to do with the new Ubuntu!

Niels

Subscribe
Share

Works !!! TNX

Just one error in the lines: not !/bin/sh but # !/bin/sh

Open xstartup file.

$ nano ~/.vnc/xstartup

Add the following line.

#!/bin/sh def export XKL_XMODMAP_DISABLE=1 unset SESSION_MANAGER unset DBUS_SESSION_BUS_ADDRESS

gnome-panel & gnome-settings-daemon & metacity & nautilus & gnome-terminal &

Save and close it. After that install GNOM

$ apt-get install ubuntu-gnome-desktop -y

Once finished, restart the droplet.

Now, it should work. I had the same issue and solved now.

In my case, all of my storage are full. Deleting files to have vacant space plus restarting the service fixed it.


Submit an answer
You can type!ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

This seems to be a common problem with Ubuntu 14.04 and gnome.

The following tutorial solved the issue for me: Ubuntu VNC Grey Screen

@machupicchu how to find ~/.vnc/xstartup file

Hi,

I’m also getting a gray screen when I login to VNC. I’m using Ubuntu 14.04. Has anyone solved this? The fixes listed here don’t work.

Thanks, Robert

@ra2233: Unity is a shell for the GNOME desktop environment, so the dconf commands should work on Unity. <br>

I’m trying to get a VNC on Ubuntu 14.04 on EC2 display the Unity desktop. <br>Should the dconf commands are gnome specific of could they work for Unity? <br>Those commands seems to be for a GUI desktop. How can I apply those to a vncserver session when my only access to my EC2 is via PuTTY SSH sesshin? <br> <br>

Or: dconf-editor > disable REQUIRE ENCRYPTION

sudo apt-get install dconf-tools <br> <br>finally: dconf > desktop > gnome > remote-access > enabled - uncheck !!! <br> <br>issue fixed. <br>Remote Desktop sharing working after reboot !!!

I think somehow this is a problem with Ubuntu even though we cannot exclude this is an issue with Digital Oceans images. Let’s post a Service Request. <br>

too

Yeah, still gray screen <br>