Question

VNC Xterm fails to display prompt

  • Posted October 1, 2014

I have installed vnc on my droplet and I can connect via tightVNC. However, I cannot see the prompt in my terminal. If I type “ls” or any other command I know something is running because I see the scrollbar change. And occasionally I see some text come on the screen. But it’s almost if I’m looking at a small subsection in the center of the terminal.

Also, my desktop is completely blank. Any icons might be on the outside and not visible.

I’m running Ubuntu 14.04. I installed

apt-get install gnome-core xfce4 firefox apt-get install vnc4server

as root.

Subscribe
Share

You might need to edit your ~/.vnc/xstartup file. The default never works for me with 14.04 (it used to in 12.04)

Here is mine that works fine. Using Gnome-panel:

#!/bin/sh

# Uncomment the following two lines for normal desktop:
#unset SESSION_MANAGER
# exec /etc/X11/xinit/xinitrc

[ -x /etc/vnc/xstartup ] && exec /etc/vnc/xstartup
[ -r $HOME/.Xresources ] && xrdb $HOME/.Xresources
xsetroot -solid grey
vncconfig -iconic &
x-window-manager  &
dbus-launch nautilus &
gnome-panel &
gnome-terminal &
gnome-settings-daemon &

Submit an answer
You can type!ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

It worked! Thanks!